re = /^(?!0$)\d+(?:[,.][05])?$/m
str = '0,5
0.5
0.7
0,9
1,0
1.0
1.4
1,4
1.5
0
0,0
0000.000
00000,00000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end