use strict;
my $str = '0,5
0.5
0.7
0,9
1,0
1.0
1.4
1,4
1.5
0
0,0
0000.000
00000,00000';
my $regex = qr/^(?!0$)\d+(?:[,.][05])?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}