const regex = /^(?!0$)\d+(?:[,.][05])?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!0$)\\d+(?:[,.][05])?$', 'gm')
const str = `0,5
0.5
0.7
0,9
1,0
1.0
1.4
1,4
1.5
0
0,0
0000.000
00000,00000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}