using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<day>0[1-9]|[12]\d|3[01])(?P<seperator>[\/-])(?P<month>0[1-9]|1[012])(?P=seperator)(?P<year>\d\d\d\d)";
string input = @"12/02/2134
00/02/2134
01/02/2134
31-12-2134
31-12/2134
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}