import re
regex = re.compile(r"(?P<day>0[1-9]|[12]\d|3[01])(?P<seperator>[\/-])(?P<month>0[1-9]|1[012])(?P=seperator)(?P<year>\d\d\d\d)", flags=re.MULTILINE)
test_str = ("12/02/2134\n\n"
"00/02/2134\n\n"
"01/02/2134\n\n"
"31-12-2134\n\n\n"
"31-12/2134\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")