import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<day>0[1-9]|[12]\\d|3[01])(?P<seperator>[\\/-])(?P<month>0[1-9]|1[012])(?P=seperator)(?P<year>\\d\\d\\d\\d)";
final String string = "12/02/2134\n\n"
+ "00/02/2134\n\n"
+ "01/02/2134\n\n"
+ "31-12-2134\n\n\n"
+ "31-12/2134\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}