const regex = /^0+\..+?\K|0+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0+\\..+?\\K|0+$', 'gm')
const str = `0010.003000
100.000
000.2000
0.0000`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);