#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\h*START\h*\n(?:\h*+(?!(?:START|STOP)\h*$)[^\n]*\n|(?R)\n)*\h*STOP\h*$"
Local $sString = "START" & @CRLF & _
"Outer" & @CRLF & _
" START" & @CRLF & _
" Inner" & @CRLF & _
" STOP" & @CRLF & _
"Outer" & @CRLF & _
" STOP" & @CRLF & _
" Inner" & @CRLF & _
" START" & @CRLF & _
"Outer 2" & @CRLF & _
"" & @CRLF & _
" START" & @CRLF & _
" inner 2" & @CRLF & _
" START" & @CRLF & _
" INNER 3" & @CRLF & _
" STOP" & @CRLF & _
" STOP" & @CRLF & _
"STOP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")