re = /^\h*START\h*\n(?:\h*+(?!(?:START|STOP)\h*$)[^\n]*\n|(?R)\n)*\h*STOP\h*$/m
str = 'START
Outer
START
Inner
STOP
Outer
STOP
Inner
START
Outer 2
START
inner 2
START
INNER 3
STOP
STOP
STOP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end