import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h*START\\h*\\n(?:\\h*+(?!(?:START|STOP)\\h*$)[^\\n]*\\n|(?R)\\n)*\\h*STOP\\h*$";
final String string = "START\n"
+ "Outer\n"
+ " START\n"
+ " Inner\n"
+ " STOP\n"
+ "Outer\n"
+ " STOP\n"
+ " Inner\n"
+ " START\n"
+ "Outer 2\n\n"
+ " START\n"
+ " inner 2\n"
+ " START\n"
+ " INNER 3\n"
+ " STOP\n"
+ " STOP\n"
+ "STOP";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}