$re = '/^\h*START\h*\n(?:\h*+(?!(?:START|STOP)\h*$)[^\n]*\n|(?R)\n)*\h*STOP\h*$/m';
$str = 'START
Outer
START
Inner
STOP
Outer
STOP
Inner
START
Outer 2
START
inner 2
START
INNER 3
STOP
STOP
STOP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);