import re
regex = re.compile(r" +.+ +\)", flags=re.MULTILINE)
test_str = ("This pack includes: \n\n\n\n\n\n"
" PEARSON.ADVANCED.REACT.JS.LIVELESSONS-iLLiTERATE ( 5.4 GiB )\n\n"
" PEARSON.BUILDING.MICROSERVICES.WITH.SPRING.BOOT.SECOND.EDITION-iLLiTERATE ( 20.7 GiB )\n\n"
" PEARSON.BUILDING.SPARK.APPLICATIONS-iLLiTERATE ( 9.199999999999999 GiB )")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")