re = / +.+ +\)/m
str = 'This pack includes:
PEARSON.ADVANCED.REACT.JS.LIVELESSONS-iLLiTERATE ( 5.4 GiB )
PEARSON.BUILDING.MICROSERVICES.WITH.SPRING.BOOT.SECOND.EDITION-iLLiTERATE ( 20.7 GiB )
PEARSON.BUILDING.SPARK.APPLICATIONS-iLLiTERATE ( 9.199999999999999 GiB )'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end