// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) +.+ +\)").unwrap();
let string = "This pack includes:
PEARSON.ADVANCED.REACT.JS.LIVELESSONS-iLLiTERATE ( 5.4 GiB )
PEARSON.BUILDING.MICROSERVICES.WITH.SPRING.BOOT.SECOND.EDITION-iLLiTERATE ( 20.7 GiB )
PEARSON.BUILDING.SPARK.APPLICATIONS-iLLiTERATE ( 9.199999999999999 GiB )";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}