const regex = /(\d+)(\s)(\w+)(\s)(\w+)(\s)(\w+)(\s)(\d){4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)(\\s)(\\w+)(\\s)(\\w+)(\\s)(\\w+)(\\s)(\\d){4}', 'gm')
const str = `CORREDORES PERSONA NATURAL MOROSOS AL 20 DE JUNIO DE 2019`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}