using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{10}(.*))[A-Za-z]+:[0-9]+\h*(?=\1$)";
string input = @"A:12345678
A:123456789
FOO:567890s123
LOREM:42 ipsum";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}