$re = '/^(?=.{10}(.*))[A-Za-z]+:[0-9]+\h*(?=\1$)/m';
$str = 'A:12345678
A:123456789
FOO:567890s123
LOREM:42 ipsum';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);