using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"mysqli_query\(\$db, ((?:[^()]++|\((?1)\))*)\)";
string input = @"mysqli_query($db, foo)
mysqli_query($db, foo())
mysqli_query($db, foo(bar(baz())))
mysqli_query($db, foo(bar(baz()+boz())))
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}