// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"mysqli_query\(\$db, ((?:[^()]++|\((?1)\))*)\)").unwrap();
let string = "mysqli_query($db, foo)
mysqli_query($db, foo())
mysqli_query($db, foo(bar(baz())))
mysqli_query($db, foo(bar(baz()+boz())))
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}