$re = '/mysqli_query\(\$db, ((?:[^()]++|\((?1)\))*)\)/';
$str = 'mysqli_query($db, foo)
mysqli_query($db, foo())
mysqli_query($db, foo(bar(baz())))
mysqli_query($db, foo(bar(baz()+boz())))
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);