re = /mysqli_query\(\$db, ((?:[^()]++|\((?1)\))*)\)/
str = 'mysqli_query($db, foo)
mysqli_query($db, foo())
mysqli_query($db, foo(bar(baz())))
mysqli_query($db, foo(bar(baz()+boz())))
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end