$re = '/(201[6-9])-(0?[1-9]|1[012])-(0?[1-9]|[12][0-9]|3[01])/';
$str = '$(date +%Y-%m-%d)
2016-07-25';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);