import re
regex = re.compile(r"(201[6-9])-(0?[1-9]|1[012])-(0?[1-9]|[12][0-9]|3[01])")
test_str = ("$(date +%Y-%m-%d)\n"
"2016-07-25")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")