re = /(201[6-9])-(0?[1-9]|1[012])-(0?[1-9]|[12][0-9]|3[01])/
str = '$(date +%Y-%m-%d)
2016-07-25'
# Print the match result
str.match(re) do |match|
puts match.to_s
end