#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<span[^>)()]*\((\d+)\)[^>]*>"
Local $sString = "<span class="b-label b-link-number" data-num="(322206)">Music & Video</span>" & @CRLF & _
"<span class="b-label b-link-number" data-num="(954218)">Toys, Hobbies & Games</span>" & @CRLF & _
"<span class="b-label b-link-number" data-num="(502981)">Kids, Baby & Maternity</span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")