import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span[^>)()]*\\((\\d+)\\)[^>]*>";
final String string = "<span class=\"b-label b-link-number\" data-num=\"(322206)\">Music & Video</span>\n"
+ "<span class=\"b-label b-link-number\" data-num=\"(954218)\">Toys, Hobbies & Games</span>\n"
+ "<span class=\"b-label b-link-number\" data-num=\"(502981)\">Kids, Baby & Maternity</span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}