#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:[1-2]?[0-9]\.[0-9]{1,4})\b[^a-zA-Z\d]{0,3}%?"
Local $sString = "11111" & @CRLF & _
"11111." & @CRLF & _
"11111.1111" & @CRLF & _
".11111" & @CRLF & _
"a111.1111" & @CRLF & _
"99" & @CRLF & _
"010" & @CRLF & _
"101" & @CRLF & _
"100" & @CRLF & _
"100.01" & @CRLF & _
"2.95%" & @CRLF & _
"19.5113%" & @CRLF & _
"5.32" & @CRLF & _
"0.0250" & @CRLF & _
"9.32" & @CRLF & _
"24.32" & @CRLF & _
"0.0023" & @CRLF & _
"30.20" & @CRLF & _
"29.23" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")