import re
regex = re.compile(r"\b(?:[1-2]?[0-9]\.[0-9]{1,4})\b[^a-zA-Z\d]{0,3}%?", flags=re.MULTILINE)
test_str = ("11111\n"
"11111.\n"
"11111.1111\n"
".11111\n"
"a111.1111\n"
"99\n"
"010\n"
"101\n"
"100\n"
"100.01\n"
"2.95%\n"
"19.5113%\n"
"5.32\n"
"0.0250\n"
"9.32\n"
"24.32\n"
"0.0023\n"
"30.20\n"
"29.23\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")