$re = '`\b(?:[1-2]?[0-9]\.[0-9]{1,4})\b[^a-zA-Z\d]{0,3}%?`m';
$str = '11111
11111.
11111.1111
.11111
a111.1111
99
010
101
100
100.01
2.95%
19.5113%
5.32
0.0250
9.32
24.32
0.0023
30.20
29.23
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);