package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:e?\d{3}|v\d{2})(?:\.|\.\d|\.\d\d)?)-((?:e?\d{3}|v\d{2})(?:\.|\.\d|\.\d\d)?)`)
var str = `m05-M14
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}