re = /^((?:e?\d{3}|v\d{2})(?:\.|\.\d|\.\d\d)?)-((?:e?\d{3}|v\d{2})(?:\.|\.\d|\.\d\d)?)/
str = 'm05-M14
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end