$re = '/^((?:e?\d{3}|v\d{2})(?:\.|\.\d|\.\d\d)?)-((?:e?\d{3}|v\d{2})(?:\.|\.\d|\.\d\d)?)/';
$str = 'm05-M14
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);