const regex = /^((?:e?\d{3}|v\d{2})(?:\.|\.\d|\.\d\d)?)-((?:e?\d{3}|v\d{2})(?:\.|\.\d|\.\d\d)?)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:e?\\d{3}|v\\d{2})(?:\\.|\\.\\d|\\.\\d\\d)?)-((?:e?\\d{3}|v\\d{2})(?:\\.|\\.\\d|\\.\\d\\d)?)', '')
const str = `m05-M14
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}