package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\n\n(.*?)Show Abstract - Show Citation`)
var str = `Plenary Papers (1)
Peer-reviewed Papers (113)
PLENARY MANUSCRIPTS (1)
First Author Index
Harrer
Plenary Papers
Some title number one
John W. Doe
2018 Physics SOmething Proceedings
Full Text: Download PDF - PER-Central Record
Show Abstract - Show Citation
PEER REVIEWED MANUSCRIPTS (113)
First Author Index
Doe · Doe2 · Doe3 · Jonathan
Peer-reviewed Papers
Some title number two
Alex White, Paul Klee, and Jacson Pollock
2018 Physics Research Conference Proceedings, doi:10.1234/perc.2018.pr.White
Full Text: Download PDF - PER-Central Record
Show Abstract - Show Citation
Some title number three
Suzanne Heck, Alex Someone, John I. Smith, and Andrew Bourgogne
2018 Physics Education Research Conference Proceedings, doi:10.2345/perc.2018.pr.Heck
Full Text: Download PDF - PER-Central Record
Show Abstract - Show Citation
..`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}