import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n\\n(.*?)Show Abstract - Show Citation";
final String string = "Plenary Papers (1)\n"
+ "Peer-reviewed Papers (113)\n"
+ "PLENARY MANUSCRIPTS (1)\n"
+ "First Author Index\n\n"
+ "Harrer\n"
+ "Plenary Papers\n\n"
+ "Some title number one\n"
+ "John W. Doe\n"
+ "2018 Physics SOmething Proceedings\n"
+ "Full Text: Download PDF - PER-Central Record\n"
+ "Show Abstract - Show Citation\n"
+ "PEER REVIEWED MANUSCRIPTS (113)\n"
+ "First Author Index\n\n"
+ "Doe · Doe2 · Doe3 · Jonathan\n"
+ "Peer-reviewed Papers\n\n"
+ "Some title number two\n"
+ "Alex White, Paul Klee, and Jacson Pollock\n"
+ "2018 Physics Research Conference Proceedings, doi:10.1234/perc.2018.pr.White\n"
+ "Full Text: Download PDF - PER-Central Record\n"
+ "Show Abstract - Show Citation\n\n"
+ "Some title number three\n"
+ "Suzanne Heck, Alex Someone, John I. Smith, and Andrew Bourgogne\n"
+ "2018 Physics Education Research Conference Proceedings, doi:10.2345/perc.2018.pr.Heck\n"
+ "Full Text: Download PDF - PER-Central Record\n"
+ "Show Abstract - Show Citation\n\n"
+ "..";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}