import re
regex = re.compile(r"\n\n(.*?)Show Abstract - Show Citation", flags=re.DOTALL)
test_str = ("Plenary Papers (1)\n"
"Peer-reviewed Papers (113)\n"
"PLENARY MANUSCRIPTS (1)\n"
"First Author Index\n\n"
"Harrer\n"
"Plenary Papers\n\n"
"Some title number one\n"
"John W. Doe\n"
"2018 Physics SOmething Proceedings\n"
"Full Text: Download PDF - PER-Central Record\n"
"Show Abstract - Show Citation\n"
"PEER REVIEWED MANUSCRIPTS (113)\n"
"First Author Index\n\n"
"Doe · Doe2 · Doe3 · Jonathan\n"
"Peer-reviewed Papers\n\n"
"Some title number two\n"
"Alex White, Paul Klee, and Jacson Pollock\n"
"2018 Physics Research Conference Proceedings, doi:10.1234/perc.2018.pr.White\n"
"Full Text: Download PDF - PER-Central Record\n"
"Show Abstract - Show Citation\n\n"
"Some title number three\n"
"Suzanne Heck, Alex Someone, John I. Smith, and Andrew Bourgogne\n"
"2018 Physics Education Research Conference Proceedings, doi:10.2345/perc.2018.pr.Heck\n"
"Full Text: Download PDF - PER-Central Record\n"
"Show Abstract - Show Citation\n\n"
"..")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")