using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{#?\s?([^}]*)\}";
string input = @"remainingUsers, plural, =1 {# more agent} other {# more agents}
friend
gender, select, female {She} male {He} other {They}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}