$re = '/\{#?\s?([^}]*)\}/m';
$str = 'remainingUsers, plural, =1 {# more agent} other {# more agents}
friend
gender, select, female {She} male {He} other {They}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);