package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{#?\s?([^}]*)\}`)
var str = `remainingUsers, plural, =1 {# more agent} other {# more agents}
friend
gender, select, female {She} male {He} other {They}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}