re = /\{#?\s?([^}]*)\}/m
str = 'remainingUsers, plural, =1 {# more agent} other {# more agents}
friend
gender, select, female {She} male {He} other {They}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end