#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<date>([1-9]|1[012])[-/.]([1-9]|[12][0-9]|3[01])[-/.]((19|20)\d{2}))"
Local $sString = "this is due on 9-2-2021 at 10:00 am" & @CRLF & _
"this is due on 9/2/2021 at 10:00 am" & @CRLF & _
"this is due on 9.2.2021 at 10:00 am"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")