using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<date>([1-9]|1[012])[-/.]([1-9]|[12][0-9]|3[01])[-/.]((19|20)\d{2}))";
string input = @"this is due on 9-2-2021 at 10:00 am
this is due on 9/2/2021 at 10:00 am
this is due on 9.2.2021 at 10:00 am";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}