import re
regex = re.compile(r"(?P<date>([1-9]|1[012])[-/.]([1-9]|[12][0-9]|3[01])[-/.]((19|20)\d{2}))", flags=re.MULTILINE)
test_str = ("this is due on 9-2-2021 at 10:00 am\n"
"this is due on 9/2/2021 at 10:00 am\n"
"this is due on 9.2.2021 at 10:00 am")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")