import Foundation
let pattern = #"(?P<date>([1-9]|1[012])[-/.]([1-9]|[12][0-9]|3[01])[-/.]((19|20)\d{2}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
this is due on 9-2-2021 at 10:00 am
this is due on 9/2/2021 at 10:00 am
this is due on 9.2.2021 at 10:00 am
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)