#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i).+(?=-emb-)"
Local $sString = "TH-246-02050-EMB-SQ-ALT2.png" & @CRLF & _
"TH-246-02050-EMB-H.png" & @CRLF & _
"TH-247-02050-EMB-LOD.png" & @CRLF & _
"TH-246-02050-EMB-H-ALT2.png" & @CRLF & _
"TH-246-02050-EMB-SQ.png" & @CRLF & _
"TH-246-02050-EMB-SQ-ALT.png" & @CRLF & _
"TH-247-02050-EMB-LOD-ALT.png" & @CRLF & _
"TH-247-02050-EMB-LOL.png" & @CRLF & _
"TH-247-02050-EMB-LOL-ALT.png" & @CRLF & _
"TH-247-02050-EMB-H.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")