$re = '/(?i).+(?=-emb-)/m';
$str = 'TH-246-02050-EMB-SQ-ALT2.png
TH-246-02050-EMB-H.png
TH-247-02050-EMB-LOD.png
TH-246-02050-EMB-H-ALT2.png
TH-246-02050-EMB-SQ.png
TH-246-02050-EMB-SQ-ALT.png
TH-247-02050-EMB-LOD-ALT.png
TH-247-02050-EMB-LOL.png
TH-247-02050-EMB-LOL-ALT.png
TH-247-02050-EMB-H.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);