use strict;
my $str = 'TH-246-02050-EMB-SQ-ALT2.png
TH-246-02050-EMB-H.png
TH-247-02050-EMB-LOD.png
TH-246-02050-EMB-H-ALT2.png
TH-246-02050-EMB-SQ.png
TH-246-02050-EMB-SQ-ALT.png
TH-247-02050-EMB-LOD-ALT.png
TH-247-02050-EMB-LOL.png
TH-247-02050-EMB-LOL-ALT.png
TH-247-02050-EMB-H.png';
my $regex = qr/(?i).+(?=-emb-)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}