using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i).+(?=-emb-)";
string input = @"TH-246-02050-EMB-SQ-ALT2.png
TH-246-02050-EMB-H.png
TH-247-02050-EMB-LOD.png
TH-246-02050-EMB-H-ALT2.png
TH-246-02050-EMB-SQ.png
TH-246-02050-EMB-SQ-ALT.png
TH-247-02050-EMB-LOD-ALT.png
TH-247-02050-EMB-LOL.png
TH-247-02050-EMB-LOL-ALT.png
TH-247-02050-EMB-H.png";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}