using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!.*Rejected.*)RC:\*.*?(?P<Capture>(Bob|David|Ted|Alice)).*";
string input = @"RC:* Hi Bob Smith<\person>
RC:* Hi David Jones *Notes Bla bla<\person>
RC:* Hi Ted Warren *Rejected <\person>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}