import re
regex = re.compile(r"(?!.*Rejected.*)RC:\*.*?(?P<Capture>(Bob|David|Ted|Alice)).*")
test_str = ("RC:* Hi Bob Smith<\\person>\n"
"RC:* Hi David Jones *Notes Bla bla<\\person>\n"
"RC:* Hi Ted Warren *Rejected <\\person>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")